Forecast 5 version 2 will become unsupported in January 2017!

Forecast 5 version 2 will become unsupported in January 2017!

 

From 1st January 2017, Forecast 5 version 2 will become unsupported. This means you will miss out on any important updates or added features available and should you encounter an issue, it will be resolved in version 3 only.

It is essential that you upgrade to version 3 today to avoid being on an unsupported version and take advantage of all the great opportunities available with Forecast 5.

As a current Forecast 5 user, you are entitled to free version upgrades and release updates. With Forecast 5 version 3, you have a significant speed increase, restructured database, a fresh look and new features being constantly implemented.

Don't get caught with an unsupported version! Contact us today to find out about moving to the latest version!